また旅

日々のこと、画面の中でのこと (今はIDCFクラウド、KUSANAGI、WordPress、Vagrant及びCodeIgniter).

Vagrant

Vagrantを1.8.5にしたらvagrant upでWarning: Authentication failure. Retrying...

沖縄から帰ってまいりました。現地でブログを更新するほどの体力もなくだい~ぶ間が空いてしまいましたが、まだブログ止めてませんよ~。

さて、沖縄ネタは後にして、Vagrantネタです。

最新の1.8.5をインストールしたところ「Warning: Authentication failure. Retrying...」が何度も表示された末にタイムアウトとなり、正常にvagrant upが終了してくれません……

ちなみに環境はWindows 10、VirtualBox 5.1.2です。調べたところ下記のページが見つかりました。

inserting newly generated public key changes file permissions of ~/.ssh/authorized_keys within guest · Issue #7627 · mitchellh/vagrant · GitHub

中の人が次のリリースで修正済みと言ってるようですが、私の環境で起きてる問題とまったく同じかは英語なんで分かりません。

VirtualBox 5.1.2ってのもとっても怪しいですしね。

とりあえず1.8.4にダウングレードしたら直るみたいですが、VirtualBox 5.1.2だと各種vagrantコマンド実行時にそのバージョンのVirtualBoxに対応してませんと言われvagrant upどころじゃなくなりました。

VirtualBoxまでダウングレードするのが面倒になり、とりあえずローカルにインストールしたPHPとMariaDBでVagrantがバージョンアップするまでやり過ごそうかと思います。

-Vagrant